Reported issues with making payments
Incident Report for IG Index Ltd
Resolved
This incident has been resolved.
Posted Jul 23, 2019 - 11:42 UTC
Monitoring
A fix has been implemented, however, we are still monitoring the results
Posted Jul 23, 2019 - 06:36 UTC
Investigating
It has been reported that there are issues with making payments on our platforms. We're investigating now at the highest priority. Please contact us at +61 (3) 9860 1734 (Australia) or +65 6390 5118 (Singapore) or +44 207 896 0079 (UK) if you need to fund your account.
Posted Jul 23, 2019 - 02:29 UTC
This incident affected: Deposits and withdrawals.