Issues with processing Card Deposits
Incident Report for IG Index Ltd
Resolved
This incident has been resolved.
Posted Mar 19, 2020 - 02:54 UTC
Update
We are continuing to monitor for any further issues.
Posted Mar 19, 2020 - 00:01 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 18, 2020 - 23:57 UTC
Investigating
We are aware of an issue with processing card deposits via MyIG. This is being investigated as a high priority. If you need any assistance with payments. Please call us at +61 (3) 9860 1734 (AU), +65 6390 5118 (SG) or +44 (0)20 7896 0079 (UK)
Posted Mar 18, 2020 - 23:44 UTC
This incident affected: Deposits and withdrawals.