Login issues
Incident Report for IG Index Ltd
Resolved
This incident has been resolved.
Posted Mar 12, 2020 - 14:24 UTC
Investigating
Some clients are experiencing issues logging in to our platforms. We're investigating now at the highest priority. Trading within the platforms and apps is still fully operational. If you're unable to log in, please continue to try.
Posted Mar 12, 2020 - 13:57 UTC