Issue with account details on MyIG
Incident Report for IG Index Ltd
Resolved
This incident has been resolved.
Posted Apr 24, 2020 - 06:15 UTC
Update
We are continuing to investigate this issue.
Posted Apr 24, 2020 - 06:07 UTC
Investigating
We are currently aware of an issue with MyIG not able to load accounts. This has been raised and we are investigating this issue as a priority. We hope to resolve this issue as soon as possible. As a workaround, you will be able to access your accounts via the mobile app or you can contact us at +61 (3) 9860 1734 (AU), +65 6390 5118 (SG), +44 (0)20 7896 0079 (UK)
Posted Apr 24, 2020 - 06:02 UTC
This incident affected: My IG.