Clients placing trades but the trades don't show on the platform.

Incident Report for IG

Resolved

This incident has been resolved.
Posted Sep 09, 2025 - 23:36 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Sep 09, 2025 - 19:29 UTC
This incident affected: Web platform, Mobile apps, MT4, L2 Dealer, and APIs.