Intermittent issues with viewing positions on platform
Incident Report for IG Index Ltd
Resolved
This incident has been resolved.
Posted May 22, 2020 - 06:07 UTC
Update
We are continuing to investigate this issue.
Posted May 22, 2020 - 06:07 UTC
Update
We are continuing to investigate this issue.
Posted May 22, 2020 - 06:06 UTC
Update
We're extremely sorry for the issues experienced earlier. Our services have resumed to normal but please contact us if you're still experiencing issues, or have a question about your account.
Posted May 22, 2020 - 06:05 UTC
Update
We are continuing to investigate this issue.
Posted May 22, 2020 - 06:05 UTC
Update
We are continuing to investigate this issue.
Posted May 22, 2020 - 05:57 UTC
Update
We are continuing to investigate this issue.
Posted May 22, 2020 - 05:25 UTC
Investigating
We are currently aware of an intermittent issue where positions are not appearing on the platform. This is being investigated by our Incident team at the highest priority. If you need to place a trade or edit a position, please contact us at 0800 409 6789 (UK), 1800 601 734 (AU), +65 6390 5118 (SG) or +27 10 344 0053 (ZA)
Posted May 22, 2020 - 05:20 UTC
This incident affected: Web platform, Mobile apps, Trading, and L2 Dealer.