Reported issues with Trading
Incident Report for IG Index Ltd
Resolved
This issue should be resolved. Please let us know if you have any issues.
Posted 25 days ago. Aug 26, 2019 - 01:59 UTC
Investigating
There are currently issues with trading on our platforms. We're investigating this now at the highest priority. Please call +44 207 896 0079 (UK), +61 (3) 9860 1734 (Australia) or +65 6390 5118 (Singapore) if you experience any issues.
Posted 25 days ago. Aug 25, 2019 - 22:44 UTC
This incident affected: Trading.