Reported issues with trading
Incident Report for IG Index Ltd
Resolved
This incident has been resolved.
Posted 3 months ago. Jul 23, 2019 - 11:42 UTC
Monitoring
A fix has been implemented, however we are still monitoring the results.
Posted 3 months ago. Jul 23, 2019 - 06:36 UTC
Investigating
Some clients have reported issues with trading. This is being investigated with high priority. If you need to edit or close a position. Please contact us at +61 (3) 9860 1734 (Australia) or +65 6390 5118 (Singapore) or +44 207 896 0079 (UK)
Posted 3 months ago. Jul 23, 2019 - 02:15 UTC
This incident affected: Trading.