Minor issues depositing via Card
Incident Report for IG Index Ltd
Resolved
This incident has been resolved.
Posted Dec 18, 2019 - 01:10 UTC
Investigating
We are currently investigating an issue where some card deposits are not being accepted. This has been raised to our IT team and is being looked into at a priority. We hope to have the issue resolved as soon as possible. If you require any assistance, please contact us at +61 (3) 9860 1734 (AU), +65 6390 5118 (SG) or +44 (0)20 7896 0079.
Posted Dec 17, 2019 - 23:16 UTC
This incident affected: Deposits and withdrawals.