Issues closing positions
Incident Report for IG Index Ltd
Resolved
This incident has been resolved.
Posted 11 days ago. Sep 09, 2019 - 08:22 UTC
Monitoring
All platforms and apps are operational. We're extremely sorry for the issues experienced yesterday, and any difficulty reaching us. We're working tirelessly to answer your queries as soon as possible. If you're still experiencing problems closing trades, please call or email, we're here to help.
Posted 14 days ago. Sep 06, 2019 - 07:57 UTC