Singapore Telephony & Live chat issues
Incident Report for IG Index Ltd
Resolved
This incident has been resolved.
Posted 3 months ago. Sep 28, 2018 - 07:45 UTC
Investigating
Singapore office is experiencing connection issues at the moment, our phone lines and live chat are currently unavailable, please contact us via email while we work to fix the issue.
Posted 3 months ago. Sep 28, 2018 - 04:12 UTC