Trading issues across our platforms
Incident Report for IG Index Ltd
Resolved
This incident has been resolved.
Posted May 21, 2020 - 16:12 UTC
Update
We are continuing to investigate this issue.
Posted May 21, 2020 - 15:50 UTC
Update
We're extremely sorry for the issues experienced earlier. Our services have resumed to normal and we are monitoring the status. Please logout and log back in.
Posted May 21, 2020 - 15:27 UTC
Update
We are continuing to investigate this issue.
Posted May 21, 2020 - 15:24 UTC
Update
We're extremely sorry for the issues experienced earlier. Our services have resumed to normal and we are monitoring the status.
Posted May 21, 2020 - 15:19 UTC
Update
We are continuing to investigate this issue.
Posted May 21, 2020 - 15:17 UTC
Update
We're extremely sorry for the issues experienced earlier. Our services have resumed to normal and we are monitoring the status.
Posted May 21, 2020 - 15:16 UTC
Update
We are continuing to investigate this issue.
Posted May 21, 2020 - 15:10 UTC
Update
We are continuing to investigate this issue.
Posted May 21, 2020 - 14:49 UTC
Update
We are continuing to investigate this issue.
Posted May 21, 2020 - 14:44 UTC
Update
We are continuing to investigate this issue.
Posted May 21, 2020 - 14:44 UTC
Update
We are continuing to investigate this issue.
Posted May 21, 2020 - 14:39 UTC
Update
We are continuing to investigate this issue.
Posted May 21, 2020 - 14:18 UTC
Investigating
There are currently issues with trading on our platforms. We're investigating now at the highest priority. If you need to deal, please call +44 207 896 0079.
Posted May 21, 2020 - 14:15 UTC
This incident affected: Web platform, Mobile apps, IG charts, Trading, Deposits and withdrawals, Login, My IG, Demo accounts, ProRealTime charts, MT4, L2 Dealer, and APIs.