Login issues
Incident Report for IG Index Ltd
Resolved
This incident has been resolved.
Posted Nov 05, 2019 - 21:44 UTC
Monitoring
Access should now be restored to our platforms and apps, and we're monitoring the situation. Please call if you still experience issues.
Posted Nov 05, 2019 - 17:52 UTC
Investigating
We're investigating an issue with logging in to the trading platforms and apps. Please call us if you need to close a trade, while we investigate this issue.
Posted Nov 05, 2019 - 17:31 UTC
This incident affected: Web platform and Mobile apps.